Is Anyone Else Seeing Duplicates?

I’m asking for some help. If you can help me troubleshoot this, please respond in the comments section of this post.

Is anyone else seeing my blog posts duplicated in their reader? Has it been going on for a while? What reader are you using? Have you ever experienced this on your blog and what was the cause?

Thanks! And I apologize for the clutter.

23 comments

  1. Scott Meade · ·

    Test comment.

  2. Scott,

    I’ve been seeing duplicates for the past week or so, although I haven’t seen one for this post yet.

    -Lee

  3. Hello.

    Been seeing duplicates on Google Reader, both from your direct feed and from your posts on Planet MicroISV. But not on this post, just as Lee.

  4. Had dupes since you started your Making of a web app series. Mainly old posts reappear as new. Using IE7/LiveMailDesktop from http://www.synapsoftware.com/blogit/xml/rss/feed.xml

  5. Scott Meade · ·

    Thanks Lee, Rodrigo, and Oliver for the input. And thank you for still taking a look at these entries even with the dupes. I’ve found other people that have had this happen, yet have not found a solution yet. Still working it.

  6. Hey Scott. I’ve been seeing dupes for a couple of weeks now. I’m using Newsgator Online. Did see a dupe of this post also.

  7. Scott Meade · ·

    George – are you using the feedburner feed ( feed://feeds.feedburner.com/synapsoftware ) or straight from this site (feed://synapsoftware.com/blogit/xml/rss/feed.xml)?

  8. Scott – I’ve also been seeing dupes for a few weeks. I’m using Google Reader with your feedburner feed. I’ll add your direct site feed to Reader as well to see if the behaviour is consistent over the next few days.

  9. Scott Meade · ·

    Thanks Dan.

  10. I’ve been seeing duplicates for a while now. I’m subscribed to the Planet Micro ISV feed using Newsgator online. The number of duplicates tends to increase as time passes, usually there’s only two copies of each post, but there’s usually 3 or 4 the next time I log in.

  11. Steve Moyer · ·

    Here’s another (potential) clue. Up until the “Making of a Web App: Part 8 – Styleguide” post, I was getting 4 copies of each article. I got 3 copies of the “Why a Big Budget Will Kill Your Software Project” and the only 2 copies each of the 3 posts related to duplicates.

    I’m guessing from the time-stamps that I didn’t receive the 4th copy of the “Big Budget” post because that’s when you changed something on your system … and that that same change has cut the duplicates from 4 to 2.

    It should also be noted that the posts don’t show up at the same time, though I can’t give you a pattern.

    I’m using Akregator embedded in Kontact.

  12. I am still seeing duplicates. I am using IE 7.0 to read my feeds.

  13. Scott Meade · ·

    Thanks Steve. That helps.

  14. Hey Scott,

    I’m not seeing any dupes: What I do see is that
    frequently all feed entries are become unread when
    it appears only one of them has changed.

    I’m using the “All the News” Eclipse plug-in, v3.0.5.

    MarkC

  15. I just got a duplicate for this post in NewsFire. It looks like I’m using your direct feed from: http://www.synapsoftware.com/blogit/xml/rss/feed.xml.

  16. Brian Yamabe · ·

    I’ve been getting duplicates with NetNewsWire for a couple of weeks using: http://feeds.feedburner.com/synapsoftware and from Planet MicroISV. No dupe of this post, yet.

  17. Oliver (the real one) · ·

    Scott, I saw a duplicate post when you did one on purpose the other day. (I guess you deleted them now?) Otherwise what I mainly see is that all the posts show as unread in my reader every time I refresh.

    RssOwl
    http://feeds.feedburner.com/synapsoftware

  18. I’m glad to know I wasn’t the only one. Scott I noticed something strange about your feedburner feed:

    Compare the two:

    http://feeds.feedburner.com/synapsoftware

    http://feeds.feedburner.com/alexwilliams

    Yours returns an XML file and mine leads to a webpage with the feed data.

    Try this, on the feedburner site, goto “My Feeds”, click your feed, choose “Optimize”, make sure “SmartFeed” and “BrowserFriendly” are activated. My theme is “ClearFeed (English)”… then save.

    That might solve the problem.

    Good luck!

  19. Scott Meade · ·

    Thanks Alex. I’ve made the changes you recommended. Anything is worth a try at this point. This post is up to 9 entries in the feedburner feed now. Still working on resolving it.

  20. Scott – Since I’ve subscribed to both your Feedburner and direct feeds, I’ve received dupes on both. Some of the dupes I received this morning were links to the 4webit.com domain instead of synapsoftware.com. This happened in both feeds. All the links resolved fine, BTW.

  21. I take it back.. i’m still seeing duplicates from yesterday’s post.

    The strange part, all 3 URLs are different:
    http://synapsoftware.com/ndi/articles/2007/06/21/use-cases
    http://synapsoftware.com/blogit/articles/2007/06/21/use-cases
    http://www.synapsoftware.com/blogit/articles/2007/06/21/use-cases

    Hope this helps!

  22. Scott Meade · ·

    This helps. Thanks everyone for the feedback.